Reconfigure OS
# touch /reconfigure # sys-unconfig
ILOM tips
- Break the
-> set /HOST send_break_action=break
- Change boot-device
show-disks printenv boot-device setenv boot-device /pci@400/pci@2/pci@0/pci@c/LSI,mrsas@0/disk setenv auto-boot? True reset-all
OS and Ldom3.0 Upgrade
pkg set-publisher -P -g http://ipkg.us.oracle.com/solaris11/dev solaris pkg update --accept pkg update -v -g ldomsmanager.p5p ldomsmanager ldoms-incorporation kernel: pkg list system/kernel
Device
- Refresh devices
# devfsadm
Configure IP address
- Solaris 10:
static IP for vnet1 # dladm show-link/show-dev # ifconfig vnet1 plumb # ifconfig vnet 10.0.0.22 netmask 255.255.255.0 up verify route and IP address # netstat -nr # ifconfig -a
- Solaris 11:
Use DefaultFixed instead of Automatic # netadm list # netadm enable -p ncp DefaultFixed. # dladm show-phys LINK MEDIA STATE SPEED DUPLEX DEVICE net1 Ethernet up 1000 full igb1 net4 Ethernet up 10 full usbecm2 net3 Ethernet unknown 1000 full igb3 net0 Ethernet up 1000 full igb0 net2 Ethernet unknown 1000 full igb2 net6 Ethernet up 1000 full vsw0 # ipadm create-ip net0 dhcp for net0 # ipadm create-addr -T dhcp net0/v4 static IP for net1 # ipadm create-addr -T static -a 10.0.0.21/22 net1/v4
Change hostname
# svccfg -s system/identity:node listprop config # svccfg -s system/identity:node setprop config/nodename = newname # svccfg -s system/identity:node setprop config/loopback = newname //don't do this to ovs sparc # svccfg -s system/identity:node refresh # svcadm restart system/identity:node
Check cpu and memory information
# prtconf # prtdiag # psrinfo -v
Mount cdrom/ISO
# iostat -En # mount -F hsfs /dev/dsk/c0d2s0 /cdrom
Change BE(Boot Environment)
If you had Solaris 11.1 installed before and you have updated the system to 11.2 (with package update) and there is a way to go back to your previous configuration. Use "beadm list", this will show the different BE (boot environment) you have. Each time you do "pkg update" to update the entire system, a new BE is created. For example: # beadm list BE Active Mountpoint Space Policy Created -- ------ ---------- ----- ------ ------- solaris - - 36.94M static 2012-01-17 16:29 solaris-1 - - 146.63M static 2012-07-02 11:16 solaris-2 - - 151.70M static 2012-07-20 14:42 solaris-3 - - 21.15M static 2012-10-04 12:04 solaris-3-backup-1 - - 217.0K static 2012-10-04 14:41 solaris-4 - - 22.28M static 2012-10-04 15:11 solaris-4-backup-1 - - 1.21M static 2012-10-16 09:01 solaris-4-backup-10 - - 6.11M static 2014-02-25 02:58 solaris-4-backup-11 - - 14.33M static 2014-03-12 17:31 solaris-4-backup-12 - - 9.46M static 2014-03-17 16:53 solaris-4-backup-13 - - 10.74M static 2014-03-19 18:51 solaris-4-backup-2 - - 386.0K static 2012-11-13 09:11 solaris-4-backup-3 - - 1.29M static 2013-03-05 15:12 solaris-4-backup-4 - - 677.0K static 2013-03-27 16:30 solaris-4-backup-5 - - 1.63M static 2013-04-05 15:35 solaris-4-backup-6 - - 853.0K static 2013-09-20 02:31 solaris-4-backup-7 - - 4.03M static 2014-01-21 15:23 solaris-4-backup-8 - - 1.05M static 2014-01-22 12:20 solaris-4-backup-9 - - 973.0K static 2014-01-22 15:52 solaris-5 - - 21.61M static 2014-03-31 15:33 solaris-5-backup-1 - - 322.0K static 2014-03-31 16:23 solaris-5-backup-2 - - 368.0K static 2014-03-31 16:27 solaris-6 NR / 41.37G static 2014-03-31 16:37 solaris-6-backup-1 - - 80.0K static 2014-03-31 16:52 solaris-6-backup-2 - - 7.80M static 2014-04-02 13:29 solaris-backup-1 - - 259.0K static 2012-01-23 17:19 solaris-backup-2 - - 277.0K static 2012-01-23 17:26 solaris-backup-3 - - 435.0K static 2012-01-31 11:27 This system is using BE solaris-6. Don't pay attention to "backup" BE. Now you need to find the old BE containing Solaris 11.1. To check the BE contain, you can mount it: # beadm mount solaris-5 /mnt # cat /mnt/etc/release Oracle Solaris 11.1 SPARC Copyright (c) 1983, 2012, Oracle and/or its affiliates. All rights reserved. Assembled 19 September 2012 # beadm unmount solaris-5 In this example, we can see that BE solaris-5 is Solaris 11.1 Once you have found your Solaris 11.1 BE, activate the BE and reboot. For example: # beadm activate solaris-5 # reboot
Packages
- Rebuild the package index
# pkg rebuild-index
- Find the Solaris Package which belongs to a given File
# pkg search -l /usr/bin/dd INDEX ACTION VALUE PACKAGE path file usr/bin/dd pkg:/system/core-os@0.5.11-0.175.1.0.0.24.2
- Find the package contents
# pkg contents -t file,link,hardlink -o action.name,mode,pkg.size,path,target system/core-os