Differences between revisions 3 and 6 (spanning 3 versions)
Revision 3 as of 2014-03-07 18:55:19
Size: 1664
Editor: frank
Comment:
Revision 6 as of 2014-03-07 18:55:59
Size: 1667
Editor: frank
Comment:
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
====Reconfigure OS==== ==== Reconfigure OS ====
Line 39: Line 39:
{{{  {{{
Line 50: Line 50:
{{{  {{{
Line 79: Line 79:
}}}} }}}

Reconfigure OS

# touch /reconfigure
# sys-unconfig

ILOM tips

  • Break the
    -> set /HOST send_break_action=break
  • Change boot-device
    show-disks
    printenv boot-device
    setenv boot-device /pci@400/pci@2/pci@0/pci@c/LSI,mrsas@0/disk
    setenv auto-boot? True
    reset-all

OS and Ldom3.0 Upgrade

pkg set-publisher -P -g http://ipkg.us.oracle.com/solaris11/dev solaris
pkg update --accept
pkg update -v -g ldomsmanager.p5p ldomsmanager ldoms-incorporation

kernel:
pkg list system/kernel

Device

  • Refresh devices
    # devfsadm

Configure IP address

  • Solaris 10:
    static IP for vnet1
    # dladm show-link/show-dev
    # ifconfig vnet1 plumb
    # ifconfig vnet 10.0.0.22 netmask 255.255.255.0 up
    
    verify route and IP address
    # netstat -nr
    # ifconfig -a
  • Solaris 11:
    Use DefaultFixed instead of Automatic
    # netadm list
    # netadm enable -p ncp DefaultFixed.
    # netadm create-ip net0
    dhcp for net0
    # netadm create-addr -T dhcp net0/v4
    static IP for net1
    # netadm create-addr -T static 10.0.0.21/22 net1/v4

Change hostname

# svccfg -s system/identity:node listprop config
#  svccfg -s system/identity:node setprop config/nodename = newname
# svccfg -s system/identity:node setprop config/loopback = newname //don't do this to ovs sparc
# svccfg -s system/identity:node refresh
# svcadm restart system/identity:node

Check cpu and memory information

# prtconf
# prtdiag
# psrinfo -v

Mount cdrom/ISO

# iostat -En
# mount -F hsfs /dev/dsk/c0d2s0 /cdrom

Tech/Solaris (last edited 2014-11-25 00:38:12 by frank)